No results when searching for IP address (or name) that is in an imported config.

Hello. I'm trying to figure out why an IP address that I know is in an imported config, is not showing up in the search results. I think I sort of understand the options in the Search For: under Search Criteria i.e. Hosts, Devices, Interfaces, etc... but not completely. For Instance, if I Search For: Devices and Search By: IP Address, I'm not going to see any and every instance of that IP address that is in a config in Redseal, correct? My guess is Devices is a categorization within Redseal, not a keyword search for just that IP (as well as a Search For: All and Search By: Name will not do the same, correct?). thanks

6replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Good question, Kevin South

    You're quite right that a search by "Devices", with Search By set to "IP Address" will not look at every single address in the config - it looks only at the interface IP addresses.

    If you want to look for any instance of "10.11.12.13", no matter where it appears (in security policies, or DNS/NTP/VTY settings, or wherever), try setting Search For to "Devices", but then set Search By to "Config File Content".  That sounds like what you need.

    Note that "Config File Content" is only a choice when you specify that you're looking for Devices - it won't be on the menu of choices if, say, you're searching for Subnets.

    Reply Like
  • Mike Lloyd -

    Thank you. I never noticed that. That should be useful. BTW - when I do that search, the Looking for Server is displayed in the bottom left of the screen while it is searching. Is it normal for that to run for awhile? Mine has been running for 10 minutes. Our map isn't large - less than 75 L3 devices. see pic.

    Reply Like
  • Hmm.  You're right - I just reproduced the same effect here, using version 8.4.2 (build 1831).  I don't know if it's good news or bad news, but I also checked the not-yet-released 8.5 release, and it worked fine.  I haven't tracked down a bug report, but it looks like this was a known problem that has recently been fixed.  Sorry about that!  If you want to contact support to report the issue, they can let you know as soon as the fix is released.

    Reply Like
  • Mike -

    I'll report it to RS support. Thanks again.

    Kevin South

    Reply Like
  • I have not been able to search using the "config file content" search, even when looking for known strings (both unique & non-unique); I get the same issue as in the above screenshot. I have found it easier to make a custom BPC to search for the string I need, then re-import my device configurations (Custom BPC will not be ran against existing, stored config files; the configs need to re-imported to be checked against the new custom BPC). I just assign the CPBC as a LOW because unfortunately, they do not provide the use of an INFO or non-severity check.

    Reply Like
  • Kevin South  & kyle cary

    Have either of you tried the config content search under 8.5.0 to test Dr. Mike's results that the search succeeds in 8.5.0 but never completes in 8.4.2 ?

     

    Thank you,

    High Mobley
    Sr. Escalation Engineer
    RedSeal, Inc.
    888-841-7695

    Reply Like
reply to topic
Like Follow
  • 6 days agoLast active
  • 6Replies
  • 171Views
  • 4 Following